Recent Posts

Pages: [1] 2 3 ... 10
1
The Bar - General Chat / Re: well..
« Last post by Thrasher on January 11, 2021, 09:22:18 »
Wotcha :)
2
The Bar - General Chat / Re: well..
« Last post by Xtremeteam on January 11, 2021, 09:18:10 »
elo
3
The Bar - General Chat / Re: well..
« Last post by Welshbreed on November 23, 2020, 20:00:17 »
i still pop in from time to time. hello all.
4
New Members - Say Hello / Re: Hello.
« Last post by Thrasher on September 20, 2020, 22:36:10 »
Welcome :)

There's a wealth of information in the forums, hope it helps :)
5
New Members - Say Hello / Hello.
« Last post by lifeonwheels on September 14, 2020, 11:57:00 »
Just joined this club and wanted to say hello. I have a small group of friends who like myself are starting out on the off road circuit we are all members of the Scottish Off Road Club. So far only one of us has done off roading in his Land Rover defender. I myself have a mk3 shogun that i'm in the process of setting up. Looking forwards to having my 4x4 do what it was made to do. ''If it ain't dirty it ain't an off roader''.
6
The Bar - General Chat / Re: well..
« Last post by MuddyMike on September 14, 2020, 07:54:44 »
Hey guys. I’m so pleased you’ve waited for me, I’ve been wandering around lost for months.
7
The Bar - General Chat / Re: well..
« Last post by Budgie on July 23, 2020, 23:17:47 »
Love the photos, Neil. You need to get yourself up here for the landscapes & waterfall images.  :wink:

I've just started into drone videos. I got a DJI Mavic Pro drone in December but due to lockdown and the weather I haven't been able to get out much. It takes some cracking 4k video and now I have some good video editing software to go with it I'm just waiting to get out into Glencoe and Glen Etive with it.  :cheesy:
8
The Bar - General Chat / Re: well..
« Last post by Thrasher on July 21, 2020, 21:33:25 »
Evening 😎
9
The Bar - General Chat / Re: well..
« Last post by hrh_dave on July 21, 2020, 21:21:46 »
Evening peeps from the Far far north of the mainland..
10
Announcements / Forum Reinstall
« Last post by Thrasher on July 21, 2020, 21:18:05 »
Hi All,

We had a lot of add-ons that sadly were not compatible and resulted in parts of the forum ceasing to function. I've reinstalled the forum so hopefully it might wake up.....maybe.
Pages: [1] 2 3 ... 10
SimplePortal 2.3.6 © 2008-2014, SimplePortal