Author Topic: dam SJ clutch, HELP.  (Read 1432 times)

0 Members and 1 Guest are viewing this topic.

Offline wingnut1

  • Posts: 14
  • Karma: +0/-0
  • Referrals: 0
dam SJ clutch, HELP.
« on: June 15, 2011, 17:54:56 »
have just fitted a new (valeo) clutch kit to my SJ410 today.
dam thing started to slip as i drove it out of the garage.
the clutch is ajusted properly as well.
it bites right at the end of the peddle.
in the end i adjusted the cable so it was so slack the thing sags down , just so i could get it to bite at a sensible height
all the components were de greased as well.
the flywheel is in good condition with no cracks or blueing.
has anyone had this problem before, and what did you do to sort it out.

Offline generation-x

  • Moderator
  • ***
  • Posts: 2057
  • Karma: +1/-0
  • Mega-Fronty
    • church stretton
  • Referrals: 0
Re: dam SJ clutch, HELP.
« Reply #1 on: June 18, 2011, 21:28:11 »
have you sorted this problem out ?

Offline wingnut1

  • Posts: 14
  • Karma: +0/-0
  • Referrals: 0
Re: dam SJ clutch, HELP.
« Reply #2 on: June 23, 2011, 20:37:32 »
well the valeo clutch is back in the box, and will be up for sale soon.
found a small firm that managed to re line the old plate and put a bit more meat on it.
job done, works a treat.
the cost to get my old plate re lined,

Offline generation-x

  • Moderator
  • ***
  • Posts: 2057
  • Karma: +1/-0
  • Mega-Fronty
    • church stretton
  • Referrals: 0
Re: dam SJ clutch, HELP.
« Reply #3 on: June 23, 2011, 20:53:05 »
super duper as long as its sorted

so you bowing out of the 4x4 offroading or going to get something else? :undecided:

 

SimplePortal 2.3.6 © 2008-2014, SimplePortal