AuthorTopic: 1990 Range Rover 3.9 v8 Starting and runing problems  (Read 2183 times)

0 Members and 1 Guest are viewing this topic.

Offline Tubs

  • Posts: 4
  • Attack: 100
    Defense: 100
    Attack Member
  • Karma: +0/-0
  • Referrals: 0
1990 Range Rover 3.9 v8 Starting and runing problems
« on: November 26, 2010, 17:47:06 »
Hi, I have a 1990 v8 vogue which I have starting and running problems with. I know this is because I flooded the engine with water while off roading earlier this year. But after taking the plugs out and clearing the water it started and ran ok for a few weeks. After this it would start run for 3-5mins and cut out. I have changed the plugs and was getting what looked like a good spark. Still I had the cutting out problem, so I started looking a the fuel system and I changed the fuel filter. Still having the same problem I left it for a few more weeks. Now I go to turn it over and it fires but it will not run. Can any one help please?
 
Thanks

Offline Range Rover Blues

  • Moderator
  • ***
  • Posts: 15217
  • Attack: 100
    Defense: 100
    Attack Member
  • Karma: +3/-0
    • South Yorkshire
  • Referrals: 0
Re: 1990 Range Rover 3.9 v8 Starting and runing problems
« Reply #1 on: November 26, 2010, 23:15:30 »
I did that, turned out it was the coil, once it got hot it started playing up.  Give it a try.
Blue,  1988  Range Rover 3.5 EFi with plenty of toys bolted on
Chuggaboom, 1995 Range Rover Classic
1995 Range Rover Classic Vogue LSE with 5 big sticks of Blackpool rock under the bonnet.

Offline Tubs

  • Posts: 4
  • Attack: 100
    Defense: 100
    Attack Member
  • Karma: +0/-0
  • Referrals: 0
Re: 1990 Range Rover 3.9 v8 Starting and runing problems
« Reply #2 on: November 27, 2010, 08:11:10 »
Thanks, I forgot to say I changed the coil as well for a brand new one. It still does the same when you turn the key it will fire but it won't run. Could it be some sort of sensor stopping it from running?

Offline gingernutsv8

  • Posts: 100
  • Attack: 100
    Defense: 100
    Attack Member
  • Karma: +0/-0
  • Referrals: 0
Re: 1990 Range Rover 3.9 v8 Starting and runing problems
« Reply #3 on: November 27, 2010, 10:36:19 »
water in the fuel tank??? drain the tank and put fresh fuel in   
If it ain't broke hit it with a big hammer then it will be.

Offline Tubs

  • Posts: 4
  • Attack: 100
    Defense: 100
    Attack Member
  • Karma: +0/-0
  • Referrals: 0
Re: 1990 Range Rover 3.9 v8 Starting and runing problems
« Reply #4 on: November 28, 2010, 09:27:57 »
I thought that water in the tank could be the problem but when I changed the fuel filter I took a bowl full of petrol out of the tank and there was no sign of water on top of the petrol. But Im no expert on how the water would sit in the tank so this could be the problem. I will give it ago.

Thanks

Offline gingernutsv8

  • Posts: 100
  • Attack: 100
    Defense: 100
    Attack Member
  • Karma: +0/-0
  • Referrals: 0
Re: 1990 Range Rover 3.9 v8 Starting and runing problems
« Reply #5 on: November 28, 2010, 10:20:26 »
water sits at the bottom of the tank so if it sits where the fuel pump is it won't suck it up. if you undo the drain plug in the tank catch the fuel in a big bowl so you can see if there is any water in it
If it ain't broke hit it with a big hammer then it will be.